Please or Register to create posts and topics.

Setup Wizard In Universal G-Code Sender

Page 1 of 2Next

I managed to get my Super Geril all hooked up and as far as I can tell everything is working.

I am at the process of trying to run the setup wizard in UGS and I am at step 14 where it tells you to skip to step 3 in the wizard. So step 1, I click next, ok, it goes to step 2 and asks for a file or next to continue, I click next and nothing happens. I wait for several minutes and nothing has happened so I double click next and it sends me to step 6! I click back trying to go back to step 3 but it goes back to step 2 again.

So I think to my self, maybe the board hasn't been programmed with firmware. I install STM-32 Link software and plug my ST-Link dongle in and follow the directions up to where I go into the Target settings. When I get to where I have to put 4 MHz, I can't change it from saying "old firmware" (picture attached).

So I am basically stuck and do not know where to go from here. I can't re-flash my firmware because I can't even get the dongle to be read on the laptop, and I can't get passed step 14 in UGS setup wizard. If anyone can help me or point me in the right direction I would be so grateful.

Oh, on a side note. I installed my own TB67S109 stepsticks, but I couldn't find any reference to setting the VRef, I put mine 0.5 mV. Does anyone know if this is the correct setting?

Edit: sorry no picture, it will not let me load it for some reason.

OK, I was finally able to update the dongle to the correct firmware. However I still can not connect to the board. I have the 4 wires from the dongle connected correctly and the settings as specified. Every time I click "OK" in settings or "connect to Target" I get the following: "Can not connect to target! If you are trying to connect to an STM32W1xx device, please select Normal or HotPlug mode from Target -> Settings menu. If you are trying to connect to a low frequency application, please select a lower SWD frequency mode from Target -> Settings menu."

I also still have the same problem with Universal G-Code Sender as above. When I click on firmware settings under Machine, nothing is appearing in the dialog box.

Also still wanting to know if my settings for the VRef on the TB67S109 StepSticks are correct.

Ok, I think I got around my Breakout pin question by someone over at Carbide2D community, I am now at a dead stop with the following Setup Wizard message:

Connected to SuperGrebil 1.1 (yay)

The setup wizard is NOT supported for this controller.

Controller = SuperGerbil Board, right?

FYI: I am running a Win 8.1 32 bit machine.

What is my Workaround/Fix?

Uploaded files:
  • IMG_3859.jpeg

Hi Corey and Rich,

firstly apologies for no response - a forum software issue has meant I've missed out on notifications of new posts.

Can I start by checking you've been referring to following pages:

SuperGerbil Board configuration

Also please confirm you're using Awesome.Tech's fork of UGS ( As you can see from our download page, UGS is only tested with Windows 10, so I can't confirm it works with Windows 8. The operating system/driver related notes on the following page (written for Mini Gerbil, but with some commonality with SuperGerbil) *may* be helpful:

MiniGerbil Troubleshooting Guide

I note that Windows 8 is on extended (minumum?) support from Microsoft so you may like to bring forward your plans to upgrade to Windows 10? Or could you get access to a laptop with Windows 10 that you could bring to the SuperGerbil to test?

Regarding stepsticks... please confirm you've configured according to the heading 'Stepstick Voltage Jumpers' on In relation to Vref, there's two approaches:
(1) design for a specific motor current. This approach involves looking up the current characteristics of your motor, deciding on a safety margin, and applying the tb67s109 formula on Vref to determine the target current.
(2) start with a low Vref and increase as needed.

In general approach 2 is easier, especially considering that even if you adopt approach 1, you may still need to tweak anyway... is that helpful?


WOW.  I see that you have attempted to answer a whole lot of questions with one reply....and I am trying to figure out what parts apply to my latest error: ((The setup wizard is NOT supported for this controller))

Yes, I am using Awesome Tech's fork of UGS 2.5

My Tablet is not able to upgrade to Win 10, so I will purchase a Win10 machine and get back to you in a few days (grrrr).

Regarding my earlier area of confusion about the Break Out pins for external Stepper Drivers.  Your instructions state exactly what is printed on the board.  That's like looking up a word in a dictionary only to find the definition is the same word you are looking up.  As I said external drivers have 6 pins, and are labeled slightly differently AND with polarity.  While I am attempting to upgrade my Shapeoko to a 4th axis, I do not possess the in-depth technical knowledge as you, and well need a little hand-holding to not let the smoke out of your lovely board.

Lastly, I think you were answering Cory's question regarding flashing the board, but since there is no such thing as a stupid question, I'll ask one.  Do I need to flash my SG Board with firmware?  ( I thought you did that and tested that it was successfully working, prior to shipping)




Uploaded files:
  • Screen-Shot-2020-01-30-at-3.51.42-PM.png

Hi Rich,

Unfortunately upgrading to Windows 10 is the very best step regarding resolving the setup wizard message at the moment. Yes, upgrading is annoying and expensive, but it does remove so many factors that could potentially be causing the problem. The only alternative you have is to follow the operating system/driver related links in the MG troubleshooting guide, but that's a not a supported activity that I can help further with.

Ah-hah, I have just seen your post re Break Out Pins. My response above had been to Corey's old question about stepsticks, but I'll go back to your Break Out Pins forum post and respond there now.

Re: SG board firmware, every unit was flashed and tested. No need for you do it yourself.


Background info:  You can just skip to the Problem area.

Good and bad news.  The Win10 laptop is in and connects to the setup wizard (good).

Following the instruction to machine selection, I select 3 axis  (good)

FYI (I have not purchased the 4th axis until I see that the SG works, I'll add the 4th at a later date),

PROBLEM: Machine Wiring

Click on X-/X+ Nothing (except a small pulse on the Y AXIS) (BAD)

Click on Z-/Z+ Nothing (except a small pulse on the Y AXIS) (BAD)

Click on Y-/Y+ These are the external Drives  Moves in the correct direction  + and - (good)


Any ideas?




I double and triple checked the wiring, and everything is correct.  I am converting a Shapeoko, which is set to 1/8 steps, so I didn't move any jumpers.


I went to the troubleshooting flowchart and it says replace step sticks = Huh??

I had a few days to think while I battled a cold, and came up with a few ideas.  One remove some variables, so I disconnected the two Y drives from the SG board, and also removed the Z driver.  This just left the X Axis driver.  I also disconnected the Shapeoko Steppers and connected a single Stepper motor (placed on the workbench so that I can check for movement and voltage).  Well, still no movement on the stepper (and no voltage).  I replaced the driver with the one originally in the Y axis position (New, never used) and still no movement or voltage at the stepper.

FYI There are 2 green LED's on the SG board.  When I press X+ or X- on UGS, one LED blinks so it appears that the board is alive and getting signal from UGS.




Thanks Richard, that's some useful debugging.

So I take it that the single stepper motor placed on the workbench wasn't loaded up (free to spin), so we can discount the possibility of insufficient stepstick current for X axis.

I'm trying to think why when you feed the X axis you got a pulse on the y axis... You mention disconnecting the 'two Y drives' from the SG board... I'm not sure what configuration you're aiming for, could you draw a diagram of your intended setup please?

Also, please send a photo of your wiring and I'll compare it the SG that I've got running my Nomad.




Note: I just answered this and hit enter and disappeared.  Odd, so here it is again.

My intention is (still) to make a 4-axis Shapeoko, but with odd and chaotic movement from the SG board, I thought I'd step back and remove some of the variables in trying to determine what went wrong.  (e.g. Just one axis drive, one motor)

I will draw up the original setup and post something today.

Page 1 of 2Next

User registration or Edit user profile